Complete setup guide, step-by-step

Could you update the installation instructions?

Hi @Mark

Add the following to the versions section:

cairocffi = 0.9.0
tinycss2 = 0.6.1
soupsieve = 1.9
backports.functools-lru-cache = 1.5

The cairocffi and tinycss2 versions should have been taken care of already in the code. The last two you definately need.

We also updated the installation instructions on

What is this for? im new on this

Cant find this ???!!!

Hola @serviciosrali19,

Este es un foro público donde usuarios de SENAITE, profesionales del sector y desarrolladores del LIMS exponen dudas de forma coherente y ordenada con el fin de obtener una solución gracias a la colaboración voluntaria de otros profesionales.

El objetivo final del foro es crear contenido de calidad de forma respetuosa, no es una plataforma de servicio técnico. Si buscas soporte profesional, siempre puedes contactar con un proveedor.

Estas tres últimas aportaciones están lejos de acometer el objetivo del foro, puedes echar un ojo a las directrices de la comunidad:


1 Like

Updated 8/28/21 for Senaite 2.0

This is the fastest, simplest way to install Senaite LIMS on Ubuntu 18.04 server for development and testing.

We will install Plone 5 and Senaite 2 in the home folder under the local user name. Start here for testing and development.

Get all dependencies and packages needed

$sudo apt-get install virtualenv
$sudo apt-get install python2.7
$sudo apt-get install build-essential gcc python-dev git-core libffi-dev
$sudo apt-get install libpcre3 libpcre3-dev autoconf libtool pkg-config
$sudo apt-get install zlib1g-dev libssl-dev libexpat1-dev libxslt1.1
$sudo apt-get install gnuplot libcairo2 libpango1.0-0 libgdk-pixbuf2.0-0
$sudo apt-get install libxslt-dev python-pil libjpeg-turbo8-dev
$sudo apt-get install git

You may need more packages depending on what is previously installed on your server.

Make a folder for LIMS in your home directory:
$mkdir ~/LIMS

Create a python 2.7 virtual environment then activate it
$virtualenv --python=/usr/bin/python2.7 --no-site-packages ~/LIMS
$cd ~/LIMS
$source bin/activate

Clone Senaite LIMS verson 2.0 from GitHub:

$git clone
$cd senaite.lims

Make sure you have PIP and wheel installed. zc.buildout and setuptools
$pip install wheel
$pip install zc.buildout==2.13.4
$pip install setuptools==44.1.1

Download to your senaite.lims directory, then bootstrap for zc.buildout:



Open buildout.cfg with your favorite text editor and change the pinned version of zc.buildout to the version you have in this virtual environment (zc.buildout = 2.13.4). That’s at the bottom in [versions] section. You may also choose to change the default admin password now. Find the section
plone-user = admin:admin
And change to

Save any changes to buildout.cfg.

OK, Here is the big moment. Time for buildout.
From your senaite.lims directory


This will take a while. There will be some warnings and plenty of messages for the buildout log. Hopefully no errors. If you get errors then post them here and the community will help diagnose problem.

If this completes without error then your ready to start working on Senaite LIMS.

Start the instance in foreground
$bin/instance fg

Wait for Zope/Plone/Senaite to start up and listen on port 8080 (or other port you set in buildout.cfg). Initialization will take a couple of minutes. Watch for error messages. Watch for listening and ready to take requests.

If all goes well, open a web browser on same machine and go to URL localhost:8080

Follow Senaite LIMS instructions for configuration.

For components like and senaite.instruments, add them to your buildout.cfg file in the eggs section. There’s an example buildout file here:

Please help! The following error occurred during setup.
$ python
File “”, line 7

SyntaxError: invalid syntax

Which are you using?

Line 7 of this is a comment line.
Also, confirm you have zc.buildout installed before running

I’m sure it works as you say, but it still prompts the same error. Also found that I ignore this step to operate senaite LIMS seems to be able to run

I’m sure it works as you say but it still prompts the same error.Can you provide your

I’ve had the same issue as @wits.

The resolution of this is below

It appears as if the wget command has downloaded an HTML file in stead of the actual file. If I enter the url ( into a browser I can get to the file, but I think we need to specify the raw url. Will try that now.

I got it working removing the created html (or html-like) file:
(Obviously not necessary if you haven’t run the wget command yet).
Downloaded the raw file from github:


Then run your command:

@dietervdwes I tried to pass. Thanks for sharing!

Thanks for sharing that great guide, which I followed for a successful installation of senaite 2.

I would ask about current state. Is it already supported by senaite 2 or still in development state ?

If it is supported, any guide for adding this addon will be helpful. The current GitHub instructions are for senaite 1.x

Hi @m3mo3_83, I do not think SENAITE Health is going to be implemented in 2.x, there are some addons for 2.x that already complement the health entities such as patients, etc

Hi @Jeff-DFWEnv I’m having trouble trying to run $python, the error that it’s regarding zc.buildout:

What could be the problem ?

Some problem with the file.
The previous release of Senaite 1.3 included a but this version 2 does not. I borrowed the file from version 1.3. I may have made a modification in mine, I can’t remember. Let me take a look and also ask the folks in lobby if they can include a with version 2.0.

I got it working removing the created html (or html-like) file:
(Obviously not necessary if you haven’t run the wget command yet).
Downloaded the raw file from github:


Then run your command: