Beginner's problems


#1

Hello everyone,
I recently started working with senaite lims (trying to establish it in our lab) and ran into some kind of problems. They might seem basic and stupid, but please bear with me.
I’m trying to create secondary samples from primaries, but I am unable to use several of the generated samples for secondaries. Has anyone the same issues? Is there any requirement for secondary samples that has to be met by the primary?
Furthermore I’m trying to change the name generation via ID Server, but whenever i use {client} or {clientId} I get an errormessage (and a sample creation with just random numbers and letters). In general I would like to freely assign a sample name to each sample - which ist not possible if I remember correctly - so I would like to add more information the generated Name (e. g. Client ID or Client Sample ID)

Kind Regards,
Johannes Raab


#2

Hi @RaabJoh and welcome!

Could you be more specific about the issues you are having with the creation of secondary samples? What is the exact problem?

Can you see the “Primary Sample” field in the sample creation form?

Regards,


#3

Thank you for your kind welcome!

Well I can actually see the “Primary Sample” field and I am also able to choose from a list of samples to generate the secondary sample from. But this ist not a complete list but only consists of about half the primary samples already generated.

Kind regards


#4

Please note that the widget for the primary samples does not display all items at once, but allows to filter and narrow the possible results down. Can you find the missing samples when you type in the first few chars of them?
Best regards, Ramon


#5

That actually was one of the first things I tried, but I simply can not find some of the generated primary samples which seems illogical to me, regarding the fact that some other samples are displayed.
Comparing the samples I find and those I can’t find, did not show any differences - at least not to me.


#6

Can the user you are using see all the samples in the Samples list? Then, this might be a bug. Would you mind reporting it into the issue tracker together with some images?

Regards,


#7

Hello Espurna,

Did that and the “error” has been resolved. But I am still struggling with generating custom-IDs for the samples, maybe you or anyone else can help.


This is the configuration in ID server I use right now. But whenever I generate a new sample by opening an AR i only get SampleID = {sampleType}-{seq:04d}
Do I have to change the ID generation on the AR? or is there no way to get more info into the ID?
Is it possible to generate extra-strings I would like to have in the ID generation? For example manufacturer or anything similar?


Generating custom-IDs for samples
#8

@RaabJoh I’ve moved your question to a more specific topic (Generating custom-IDs for the samples) so new users can found inromation easily. I hope you do not mind :slight_smile: .


#9

Of course I do not mind. Just did not want to bother everyone by spamming new threads all the time :slight_smile:
Thank you for moving it.