Cannot change AR's state from "Received" to "Submit for verification"


#1

Dear colleagues,

I am playing senaite.lims 1.2.0 with Plone-4.3.15 on CentOS Linux release 7.5.1804 (Core). I created an AR (s1-0002-R01) with sample (s1-0002), and now sample’s steate is “sample received” while AR’s state is “Recieved”. When I tried to change AR’s state to “Submit for verification”, “No items selected” error message showed up.

What exactly does this item mean? In Step 1 screen, I did select analyses. Maybe I need to do more with the samples or setups in order to make the transistion?

Thanks a lot in advance! – Lei

Step1:

Step2:


#2

@fatfatcoyote to be able to perform the transition you should introduce the results of the analysis.

Can you try filling the fields marked in red and trying the transition again?

Let me know if that solves your issue!


#3

Thanks a lot, juangallostra!

I filled in values (e.g., 6) to both result fields, then clicked “Submit for verification”, but got the same error message: “No items selected”, while those values were not saved.

Thanks again!
Lei


#4

@fatfatcoyote That is weird. If you have both:
1- Filled the results field
2- Selected the analyses

You should be able to perform the transition.

The warning “No items selected” might be due to the fact that, although having entered the results, you didn’t select any analysis to be submitted for verification?


#5

juangallostra,

Somehow I don’t have “submit” button showing up, which should be the reason. Not sure why though.

Thanks a lot!
Lei


#6

Hi @fatfatcoyote, this is wired… Which version of Senaite you are using?

Very silly, but have you tried to push Ctr+F5 in order to update the cached javascript?


#7

Espurna,

CTRL+F5 seems no effect in this case.
I am playing senaite.lims 1.2.0 with Plone-4.3.15 on CentOS Linux release 7.5.1804 (Core).

Thanks!


#8

Could this be related to worksheet? First all, I did not (and don’t know how to) associate a worksheet to an AR or sample.
Secondly, I could only add a worksheet (but not being used at all). But when setting up a worksheet template, it seems that I could not add a analyses to it.


#9

The source code of the troubled area (missing submit button):

    <tfoot>

      <tr>
        <td class="noborder" colspan="15">

          <table style="margin:0" width="100%">
            <tr class="noborder">

              

              <td class="workflow_actions">
                <input type="hidden" id="restricted_transitions" value="submit,retract,verify"/>

                <input type="hidden" id="hide_transitions" value=""/>

                
                  
                

                <span class="workflow_action_buttons">
                </span>
              </td>
              <td class="batching" style="text-align:right">

                
                <span class='number-items'>1 Item</span>

                

              </td>
            </tr>
          </table>
        </td>
      </tr>
    </tfoot>

#10

@fatfatcoyote Let’s see if I’m getting it right. If you:

  1. Fill in the results
  2. Select the analyses to be subtmitted for verification
  3. Select “Submit for verification”

Then the message “No items selected” appears on your screen?

With respect to the other comment, the issue you are facing probably has nothing to do with worksheets.

Can you update to the latest release of senaite.core (if you aren’t already using it) which is currently 1.2.6 and see if that changes anything?


#11

Juangallostra,

The problem was: “Submit for verification” is not showing up at all, thus no way to do step 3.

The good news is that after re-installing senaite.lims 1.2.0 (which should be based on senaite.core 1.2.6), and using English version instead of Chinese version, that problem seems gone. I can conduct Step 3 without getting error message.

My new questions are:
Now my AR S-0001-R01 is in “Sample preparation” state (why?), and how to publish results? From the old Bika docs, I did not get much clue.
How the states of AR and samples got transitioned (in the below log images), which look different from Bika’s document.

Thanks!

image

image

image


#12

@fatfatcoyote I’m glad you were able to find a solution to your problem!

With the regards to the new questions you have, would yo mind to open a different topic for them? This way we keep one topic per post and stick its contents to the original title. Furthermore, this is useful later because then a quick look a the post titles gives a hint of what you’ll find inside of the post.

Thanks, and have a nice day!