How to install SENAITE health

Hi,

I’m new to this community and i would like to know how to install SENAITE lims on SENAITE.
[https://github.com/senaite/senaite.health]
According to this guide i got this error,

```
$ buildout
Installing instance.
Version and requirements information containing senaite.lims:
  Base installation request: 'Plone', 'Pillow', 'senaite.lims', 'senaite.health', 'simplejson', 'plone.recipe.zope2instance'
  Requirement of senaite.health: senaite.lims<1.4.0
  Requirement of senaite.health: senaite.lims>=1.3.4
  Requirement of senaite.lims: setuptools
  Requirement of senaite.lims: senaite.jsonapi>=1.2.3
  Requirement of senaite.lims: senaite.impress>=1.2.4
  Requirement of senaite.lims: senaite.core.spotlight>=1.0.3
  Requirement of senaite.lims: senaite.core.listing>=1.5.2
  Requirement of senaite.lims: senaite.core<1.4.0
  Requirement of senaite.lims: senaite.core>=1.3.4
  Requirement of senaite.panic: senaite.lims>=2.0.0rc1
  Requirement of senaite.lims<1.4.0: setuptools
  Requirement of senaite.lims<1.4.0: senaite.jsonapi>=1.2.3
  Requirement of senaite.lims<1.4.0: senaite.impress>=1.2.4
  Requirement of senaite.lims<1.4.0: senaite.core.spotlight>=1.0.3
  Requirement of senaite.lims<1.4.0: senaite.core.listing>=1.5.2
  Requirement of senaite.lims<1.4.0: senaite.core<1.4.0
  Requirement of senaite.lims<1.4.0: senaite.core>=1.3.4
  Requirement of senaite.lims>=1.3.4: setuptools
  Requirement of senaite.lims>=1.3.4: senaite.jsonapi>=1.2.3
  Requirement of senaite.lims>=1.3.4: senaite.impress>=1.2.4
  Requirement of senaite.lims>=1.3.4: senaite.core.spotlight>=1.0.3
  Requirement of senaite.lims>=1.3.4: senaite.core.listing>=1.5.2
  Requirement of senaite.lims>=1.3.4: senaite.core<1.4.0
  Requirement of senaite.lims>=1.3.4: senaite.core>=1.3.4
While:
  Installing instance.
Error: There is a version conflict.
We already have: senaite.lims 1.3.4
but senaite.panic 2.0.0 requires 'senaite.lims>=2.0.0rc1'.
```

In the reply section one developer told this.

senaite.health 1.x series should point to senaite.panic 1.x series…

You can work it around by adding the version restriction here: https://github.com/senaite/senaite.health/blob/1.x/setup.py#L38-L40

    install_requires=[
        "archetypes.schemaextender",
        "senaite.lims>=1.3.4",
        "senaite.lims<1.4.0",
        "senaite.panic<1.2.0",
    ],

But, I don’t know how to install it manually. Can someone please help me?

Hi @oshanJayakody,
you can pin this version in your buildout.cfg in the [versions] section:

[versions]
senaite.panic = 1.0.1

Then re-run the buildout script as described here: https://www.senaite.com/docs/installation#install-senaite

Regards, Ramon

1 Like

Thank you so much@ramonski for the help.
But I think I got it installed manually by saving the extension in SRC folder and adding it to develop location