How to publish results for an AR?


#1

Dear colleagues,

I have an AR S-0001-R01 which is in “Sample preparation” state, and its sample S-0001 is in “Sample preparation (Complete)” state. How to publish results for this AR? Thanks a lot in advance! – Lei


#2

Hi,

I’ll be working on this today, and so I’m interested: are you using the Sample Preparation workflows? I’m considering removing this functionality and replacing it with a separate addon package.



#3

Rockfruit,

Really appreciate all your efforts! In my environment, the only available “Preparation workflow” is “Simple one-step”. Am I missing something?

By the way, what should I fill in for those “<m” and “>m” in “AnalysisService1” line?


#4

Well, simple one-step is basically just a demo included in the package. It was envisioned that a user who had some more complex sample preparation steps would create their own DCWorkflow configuration via Zope’s ZMI interface. If the workflow’s ID begins with ‘sampleprep’, then it’s title would be shown here, and the Sample/AR/Analyses would freeze between “Sample Due” and “Sample Recieved” while the steps defined in the custom workflow were completed. Are you intending to have some extra steps there, outside of the normal workflow that takes place for Samples and ARs, for forcing workflow steps related to preparation of your samples?

The textboxes you indicate should probably not be present in the UI - they were intended for configuring results-range specifications manually for each specific service in this AR - and the original user of this functionality was actually inserting these values automatically via the API when ARs were automatically created by their system. You can visit site-setup as outlined in the image attached, and uncheck the box marked “Enable AR Specifications” to remove them. IMO this should be the default. I’ll start a discussion in the gitter channel about this.


#5

Hi @fatfatcoyote , preparation workflow will be removed in short, so you will not see that field in the Analysis Request Add view anymore. Meanwhile, just leave the value for that field as empty (instead of selecting “Simple one-step”).

Those “<m” and “>m” fields are automatically filled when an Analysis Specification is selected. You can use these fields to override the default values set by the Specifications or set your own specs for AR to be created. These fields only appear here if you have the “Enable AR Specifications” field (in Setup > Analyses) enabled. In most cases, labs don’t need these fields to be displayed/overrided, so you might consider to disable it.


#6

Rockfruit and Xispa,

Would you please advise
(1) how to publish results for an AR? So far I don’t see I can proceed with my AR or sample. Maybe because my AR or sample are in wrong states?
(2) any documentation on how to add/configure customized Workflows. I don’t find much from https://demo.bikalabs.com/knowledge-centre/manual/bika-3-user-manual.

Thanks a lot for your efforts!


#7

@fatfatcoyote hi, will you be willing to help me test the migration to fix this issue? If so, and you have some time today, please join the chat at https://gitter.im/senaite/Lobby and we can go forward.

Also, since this discussion is dissolving into different issues, it would probably be best for us to discuss these there.


#8

This issue is fixed now, should be included in next released senaite.core.


#9

#10

Rockfruit and Xispa,

Thanks a lot for your fix! When will the release be ready? Maybe I can try to get the newest git repo and compile.

Would you please advise
(1) how to circumvent the issue in the current release? I mean if there is a way to use other workflow or add/configure customized Workflows, then I can make some fresh new ARs and samples and move forward till publishing the results.
(2) any documentation on how to add/configure customized Workflows and other configurations. I don’t find much from https://demo.bikalabs.com/knowledge-centre/manual/bika-3-user-manual.

Thanks,
Lei


#11

We usually release every 3-4 weeks and the last release was published on July 10th, so the next release will probably be published by the end of July - first week of August.

(1) how to circumvent the issue in the current release? I mean if there is a way to use other workflow or add/configure customized Workflows, then I can make some fresh new ARs and samples and move forward till publishing the results.

Easy as leaving the “Preparation Workflow” field empty when creating an AR. Or better, just get rid of that field by making use of “Manage Fields” button at the top of the AR Add form.

(2) any documentation on how to add/configure customized Workflows and other configurations. I don’t find much from https://demo.bikalabs.com/knowledge-centre/manual/bika-3-user-manual.

For configuring workflows, you need to be skilled with Plone and Zope. You could edit the workflows manually through ZMI, but we don’t recommend that unless you know exactly what you are doing.