Plone>=4.3.20 error

Hi,

I came across this error (Error: The requirement (‘Plone>=4.3.20’) is not allowed by your [versions] constraint (4.3.19)). Hope to get some advise. Where can I get Plone 4.3.20? Thanks.

Regards,
MF

(base) senaite@lmunfai-A8E:~/senaitelims$ PYTHONHTTPSVERIFY=0 buildout
Uninstalling unifiedinstaller.
Uninstalling zopepy.
Uninstalling backup.
Uninstalling repozo.
Uninstalling instance.
Installing instance.
Getting distribution for ‘senaite.lims’.
Got senaite.lims 1.3.5.
Getting distribution for ‘simplejson==2.5.2’.
In file included from /home/senaite/miniconda2/include/python2.7/Python.h:83,
from simplejson/_speedups.c:1:
simplejson/_speedups.c: In function ‘encoder_listencode_obj’:
/home/senaite/miniconda2/include/python2.7/object.h:439:18: warning: comparison of distinct pointer types lacks a cast
439 | (Py_TYPE(ob) == (tp) || PyType_IsSubtype(Py_TYPE(ob), (tp)))
| ^~
simplejson/_speedups.c:2263:36: note: in expansion of macro ‘PyObject_TypeCheck’
2263 | else if (s->use_decimal && PyObject_TypeCheck(obj, s->Decimal)) {
| ^~~~~~~~~~~~~~~~~~
simplejson/_speedups.c:2263:61: warning: passing argument 2 of ‘PyType_IsSubtype’ from incompatible pointer type [-Wincompatible-pointer-types]
2263 | else if (s->use_decimal && PyObject_TypeCheck(obj, s->Decimal)) {
/home/senaite/miniconda2/include/python2.7/object.h:439:60: note: in definition of macro ‘PyObject_TypeCheck’
439 | (Py_TYPE(ob) == (tp) || PyType_IsSubtype(Py_TYPE(ob), (tp)))
| ^~
/home/senaite/miniconda2/include/python2.7/object.h:437:50: note: expected ‘PyTypeObject *’ {aka ‘struct _typeobject *’} but argument is of type ‘PyObject *’ {aka ‘struct _object *’}
437 | PyAPI_FUNC(int) PyType_IsSubtype(PyTypeObject *, PyTypeObject *);
| ^~~~~~~~~~~~~~
zip_safe flag not set; analyzing archive contents…
simplejson.tests.init: module references file
Got simplejson 2.5.2.
Version and requirements information containing plone:
[versions] constraint on plone: 4.3.19
Base installation request: ‘Plone’, ‘Pillow’, ‘senaite.lims’, ‘simplejson’, ‘plone.recipe.zope2instance’
Requirement of plone.recipe.zope2instance==4.4.1: ZODB3>=3.9
Requirement of plone.recipe.zope2instance==4.4.1: Zope2>=2.12.1
Requirement of plone.recipe.zope2instance==4.4.1: zc.recipe.egg
Requirement of plone.recipe.zope2instance==4.4.1: mailinglogger
Requirement of plone.recipe.zope2instance==4.4.1: setuptools
Requirement of plone.recipe.zope2instance==4.4.1: zc.buildout
Requirement of senaite.lims: Plone<5
Requirement of senaite.lims: Plone>=4.3.20
Requirement of Plone==4.3.19: wicked
Requirement of Plone==4.3.19: plone.app.theming
Requirement of Plone==4.3.19: plone.app.openid
Requirement of Plone==4.3.19: plone.app.iterate
Requirement of Plone==4.3.19: plone.app.dexterity
Requirement of Plone==4.3.19: plone.app.caching
Requirement of Plone==4.3.19: Products.CMFPlone
Requirement of Plone==4.3.19: Products.CMFPlacefulWorkflow
Requirement of Plone==4.3.19: setuptools
While:
Installing instance.
Error: The requirement (‘Plone>=4.3.20’) is not allowed by your [versions] constraint (4.3.19)

Same principle applies for the upgrade of Plone within 4.3.x series: Upgrading Plone 5 Within 5.x.x Series — Plone Documentation v5.2. Just do the proper changes in your buildout cfg file, so 4.3.20 version is used instead of 4.3.19

Hi Jordi,

The problem is that Plone 4.3.20 is not available for downloading from Plone 4.3.20 — Plone: Enterprise Level CMS - Free and OpenSource - Community Driven - Secure. Do you have any suggestion?

As per the error you posted above, it assumed you already had a prior version of Plone installed in your system. Or at least, buildout. In such case, you don’t need to download anything manually, you only need to do the changes suggested in your buildout config file and run the bulidout again. buildout will manage to automatically download the correct versions of everything by its own.

If you want to get Plone 4.3.20 manually, you can always download the egg from pypi (Plone · PyPI) and place it in your buildout-cache/downloads/dist folder. Still, you’ll need to run bin/buildout anyways.

So again, you only need to replace 4.3.19 by 4.3.20 in your buildout.cfg in run bin/buildout again. More information about how buildout tool works: Buildout, an automation tool written in and extended with Python — Buildout 2.7 documentation

1 Like