Issues Upgrading from 1.3.2 -> 1.3.3 (and

Hey Senaite Team! I am having a bit of a problem with the upgrade from 1.3.2 -> 1.3.3 ( I read the documentation at and SENAITE LIMS v1.3.3 has released but am still struggling to update my live implementation site.

My Senaite installation has a custom add-on for my lab, senaite.core checked out as source code, and a site that has been live since Senaite.LIMS v1.2.x which is now currently on v1.3.2.

Originally I thought my issue was due to my add-on or checked out source code. However, I am able to build a fresh instance with senaite.core/senaite.lims = 1.3.2 and my add-on installed, and upgrade all the way the, so I believe the issue is with upgrading the older site’s data. When trying to run the upgrade from senaite.core/senaite.lims 1.3.2 to 1.3.3 I get this error:

2020-05-06T18:38:07 ERROR Zope.SiteErrorLog 1588804687.280.395866719842 http://localhost:8080/nallims/portal_quickinstaller/prefs_reinstallProducts
Traceback (innermost last):
  Module ZPublisher.Publish, line 138, in publish
  Module ZPublisher.mapply, line 77, in mapply
  Module ZPublisher.Publish, line 48, in call_object
  Module Products.CMFCore.FSPythonScript, line 127, in __call__
  Module Shared.DC.Scripts.Bindings, line 322, in __call__
  Module Shared.DC.Scripts.Bindings, line 359, in _bindAndExec
  Module Products.PythonScripts.PythonScript, line 344, in _exec
  Module script, line 11, in prefs_reinstallProducts
   - <FSPythonScript at /nallims/portal_quickinstaller/prefs_reinstallProducts>
   - Line 11
  Module Products.CMFPlone.QuickInstallerTool, line 100, in upgradeProduct
  Module Products.GenericSetup.upgrade, line 166, in doStep
  Module bika.lims.upgrade, line 68, in wrap_func_args
  Module bika.lims.upgrade.v01_03_003, line 352, in upgrade
  Module bika.lims.upgrade.v01_03_003, line 694, in mark_samples_with_partitions
  Module bika.lims.api, line 662, in search
  Module collective.indexing.monkey, line 99, in searchResults
  Module collective.indexing.queue, line 39, in processQueue
  Module collective.indexing.queue, line 165, in process
  Module collective.indexing.indexer, line 80, in reindex
  Module collective.indexing.indexer, line 57, in reindex
  Module Products.Archetypes.CatalogMultiplex, line 118, in reindexObject
  Module Products.CMFPlone.CatalogTool, line 349, in catalog_object
  Module Products.ZCatalog.ZCatalog, line 476, in catalog_object
  Module Products.ZCatalog.Catalog, line 340, in catalogObject
  Module Products.ZCatalog.Catalog, line 284, in updateMetadata
  Module Products.ZCatalog.Catalog, line 408, in recordify
  Module plone.indexer.wrapper, line 65, in __getattr__
  Module plone.indexer.delegate, line 20, in __call__
  Module Products.CMFPlone.CatalogTool, line 210, in getObjSize
  Module Products.Archetypes.BaseObject, line 559, in get_size
  Module, line 321, in get_size
  Module, line 129, in get_size
  Module, line 52, in openBlob
SystemError: error return without exception set

Any thoughts on what is causing this error? I tried looking into it, but got a little lost after I got to the collective.indexing.monkey call in the senaite.core.api module.

This site is currently a standalone zope instance (not the production site yet on a zeo), so my steps to test the upgrade from 1.3.2 to 1.3.3 went as follows:

(1) Built a fresh instance with senaite.core (v1.3.2) and my addon checked out as source, and pinned senaite.lims = 1.3.2 in my buildout.cfg and let the egg be picked up by buildout (along with the newest versions of senaite.impress and senaite.api).
(2) Copied my Filestorage/ and Blobstorage/ files from my old instance to my new instance.
(3) Started Plone
At this point my new site appears to be working identically to my old site. All TTW workflows appear to work fine
(4) Stopped Plone
(5) Change pin in buildout.cfg to senaite.lims = 1.3.3 (or I have tried both)
(6) Navigate to ~/senaite/instance/src/senaite.core and checkout the “Release 1.3.3” commit from March 4th
(7) Rerun buildout to pick up the new versions
(8) Start Plone again
(9) Navigate to http://localhost:8080/senaite/portal_setup/manage_upgrades
(10) Select to upgrade bika.lims 1.3.2 - 1.3.3
(11) Error above is outputted.

I am currently considering just ripping out all of the data and migrating it to a new site since this is not a full production site anyway. However, I’m trying to learn Plone/Senaite as robustly as possible, so any direction to troubleshooting this would be appreciated since once it is a production site I would like to be able to follow along with updates without complete re-builds.