The requirement ('beautifulsoup4==4.9.3') is not allowed by your [versions] constraint (4.11.1)


I have a problem with Senaite 2.5.
Installs senaite 2.5 on new ubuntu 20.04 server.
When trying to create an instance using the:

I receive this message:
“Error: The requirement (‘beautifulsoup4==4.9.3’) is not allowed by your [versions] constraint (4.11.1)”

My version section in file buildout.cfg looks like this:


zc.buildout =
setuptools =
Pillow = 5.1.0
cssselect2 = 0.2.2
soupsieve = 1.9.5
plone.recipe.unifiedinstaller = 5.2b1
buildout.sanitycheck = 1.0.2
collective.recipe.backup = 4.1.0

and requirements.txt l


I am asking for help as to what is causing the error ?

Help :pray:

There’s a strange thing with this library. I changed to beautifulsoup4 4.9.3 and in requirements.txt i changed soupsieve to 2.5 but it didn’t help. I keep getting the same message. Plone 5.2.14 and Phyton 3.8 are installed as recommended for version 2.5. And it still looks like this:

(senaite) senaite@ubuntu-zms:~/senaitelims$ PYTHONHTTPSVERIFY=0 buildout
Section buildout contains unused option(s): ‘deprecation-warnings’.
This may be an indication for either a typo in the option’s name or a bug in the used recipe.
Installing instance.
Version and requirements information containing beautifulsoup4:
[versions] constraint on beautifulsoup4: 4.11.1
Requirement of senaite.impress==2.5.0: beautifulsoup4==4.9.3
Requirement of zope.testbrowser: BeautifulSoup4
Installing instance.
Error: The requirement (‘beautifulsoup4==4.9.3’) is not allowed by your [versions] constraint (4.11.1)
(senaite) senaite@ubuntu-zms:~/senaitelims$

Maybe someone has an idea what this is about…? :pleading_face:

you may need beautifulsoup4 old version 4.9.3

by the way, do you use python3?
as i understanding that python3 is not compatibility with senaite 2.5

Now I see that Python 3.8 may actually be a problem. When choosing this version, I followed the recommendations from Plone

On Github, the recommendation for Senaite 2.5 is Plone 5.2.14.

The release-notes of Plone 5.2.14 recommend Phyton 3.8

## Python compatibility

This release supports Python 2.7 and 3.8.
Plone 5.2 still supports Python 2.7, but this is end-of-life since 2020. It should only be used as a temporary stepping stone before you migrate your Plone site to Python 3.

I installed beautifulsoup4 version 4.9.3 several times; and nothing helped. I’ll try it again tonight and write about the results

Python 3 is not (yet) supported.
Read more here:

Thank you all for your help :+1: :grinning:

I think I was too ambitious in trying to run Senaite 2.5 on Phyton 3.8 in reference to Plone 5.2.14.

Finally, I cleaned the Ubuntu OS and returned to Phyton 2.7 and Senaite works :grinning: